谷歌允许开发者从两个应用中选择一个,不允许android应用带来鸿蒙SDK?如何解读?

近日,有APP开发者在网络上晒出了谷歌的一款邮件。邮件中显示,他开发的APP,由于其中带有华为HMS的SDK,被拒绝上架谷歌的Google play。

不仅如此,谷歌甚至还表示称,在120天之后,任何包含华为HMS的SDK的应用更新都会被拒绝,意思是谷歌的Google Play上,就不允许有含HMS SDK的APP存在。

针对这个消息,有人表示,这是谷歌也害怕华为的鸿蒙系统了,因为含有HMS的SDK的APP,就是用于华为鸿蒙系统的,谷歌此举,就是在逼开发者二选一。

那么APP中含HMS的SDK,或者含GMS的SDK是怎么回事呢?

我们知道华为有自己的移动服务,称之为Huawei Mobile Services(HMS),HMS含各种api接口、服务等。HMS对应的是谷歌的GMS(Google Mobile Services)。

如果一款APP,要上架华为的应用商店AppGallery的话,那么就要使用华为的HMS,使用华为提供的API接口等。如果要上架谷歌的应用商店Google Play的话,就要使用谷歌的GMS,使用谷歌的API接口等。

由于现在不管是华为鸿蒙系统也好,华为的基于安卓的EMUI系统也好,都是支持安卓APP的。所以之前有很多的开发者开发了一款APP,想同时上架华为、谷歌的应用商店,为了省事,可能就会在APP中同时使用GMS、HMS的SDK。

以前谷歌可能睁一只眼、闭一只眼,也就不管你了,只要符合GMS的标准,就让你上架Google play,至于多出来的HMS的SDK可能就当做没看见。

但现在,谷歌觉得不能放之任之,就要求上架Google Play的APP中,不能有HMS的SDK,只能有GMS的SDK,意思是你想上架华为的AppGallery,使用于鸿蒙系统的话,那请重新再编译一次,不能图省事,直接在APP中,搞了两套东西出来。

这究竟算不算谷歌逼着开发者二选一?我认为不是的,毕竟开发者可以再编译一下,就可以用到鸿蒙系统上去了,谷歌没说不准你用于鸿蒙啊。

我认为谷歌这个要求是合情合理的,上架自己的应用商店的东西,还含有友商的SDK,换成谁也不同意啊,你觉得呢?

不过从另外一方面来讲,也说明鸿蒙还是让谷歌感到压力了,否则就依然还是像以前一样,当作没看到的。

发表评论

您的电子邮箱地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据